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1

1: Responder® 5 ADT Interface
Introduction

Responder® 5 (R5) ADT Interface (Interface) is a Server application sold for use on a
customer-provided Application Server. The Application Server sits between a facility’s
ADT system and the R5 system—and provides the R5 system with ADT bed census and
patient data.

ADT System Responder System

Application Server

Hospital ADT System
5 L (RSApps, RTLS, Sync, ADT)

WA

RS Apps/PC Console

(

Figure 1: Interface Overview

The Interface is a self-contained application that can be installed and compatibility-tested
with or without the remainder of the Responder system. It includes a web service that can
be password-accessed by any PC running Microsoft Internet Explorer 6.0 or later.

Diagnostic monitoring, reporting, and a live input port are included to facilitate complete
testing.

Page 6 of 81



KI-2246C Responder 5 ADT Interface—Installation, Setup, and Service

Revision History

This is the “C” version, which documents the “T12” iteration of the Interface. Since the
“B” version, we have made many changes, including the addition of additional sections
and chapters.

Scope of this Document

Read this document if your duties include installing/maintaining the Interface. Note: it does
not deal with the effect of patient information once it is passed on to the rest of the Rauland
solution.

Customer Connection
CUSTOMER CONNECTION

You can use Rauland’s secure Customer Connection site to find, view, and/or download
many support documents—including manuals, drawings, and reports. To request an
account, follow the online instructions at: http://customerconnection.rauland.com.

Related Documents

Other, related information can be found in the following documents:

Responder 5 Integration to ADT Systems (HANOQ053)

Responder 5 ADT and RTLS Integration Pre-requisites (H3513TB)
Responder 5 in Your Data Center (HANOOG5)

Responder 5 Server Management (HANO0092)

Responder 5 Configuration Guide (KI1-2237)

Responder 5 PC Console User Guide (KI-2229A)

AR N N N NN
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Alerts, Precautions, and Limitations

v The Interface is compatible with systems using the HL7 2.2—2.5 protocols. See the
Responder 5 Integration to ADT Systems (HANO0053) for details regarding
compatibility and supported trigger events.

v" The Interface can be installed, connected to an ADT system, and gather patient
information; it cannot pass that information to the remainder of the R5 system without
an ADT Interface license (located on the Responder Application or Responder
Database Server).

v'Leave the Rauland Responder connection unconfigured during initial testing to prevent
test data from being passed to the Responder system.

Host Requirements

The installation must meet the following Server Host and Client requirements:

Server Host Requirements

The Host Server should meet the following minimum requirements:

Item Minimum Requirements
Operating Svstem Microsoft™ Windows Server 2008 Standard Edition, 5 CAL - IP Version 4
P g5y only. (The OS is not compatible with IP Version 6).

Microsoft™ SQL Server 2008 with defaults plus:
e Management Studio option

Database . . . L .
o Database Engine option, with Text and Replication sub-options enabled
e Login with admin rights available for Rauland use

1S I1S, version 7 (with 11S management compatibility)

Processor Intel Core 2 Xeon CPU @ 2.4 GHz, 4MB cache

RAM 4GB DDR2 667 MHz

Hard Disk (2) 250 GB SATA2 7.2 KRPM

RAID SATA2 RAID controller - RAID 1

Drives DVD R/W
USB port

Table 1: Application Server Host Requirements

Client Host Requirements

All Clients must be running Microsoft Internet Explorer 6.0 or later.
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Packing List

The Interface “kit” ships with the following:

. Part
Quantity Part Reference
1 Installation, Setup, and Service Guide (on CD) KI-2246
1 Release Notes (on CD)
1 Responder 5 Integration Applications CD

Table 2: Packing List
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2: Installation and Setup Overview

We strongly recommend that you observe the following installation and setup steps in the order

presented.

What You Must Do ...

Where/How To Do It...

Gather all information and resources

Review the pre-installation and pre-setup sections.

Install the Server Application

Load the Install CD, and follow the prompts.

Logon as Admin

Admin | Admin01 (default login and password)...

Configure an ADT port

See setup step 1, (requires IS capability to send
controlled events).

Complete the initial (day 1) tests

See setup steps 2, 3, and 4.

Start a live feed for overnight test

Involve IS for this step.

Review the overnight test results

See setup steps 5, 6, and 7.

Complete the ADT Bed list

See setup step 8.

Configure the Rauland connection

See setup step 9 (requires working Responder 5
system).

Map ADT Beds to Rauland Beds

See setup steps 10 and 11.

Map ADT fields to Rauland Fields (optional)

See setup step 12.

Table 3: Installation and Setup Steps
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3: Preparing for Installation

You must have the following equipment and resources prior to installation:

v" A Host Server that meets all documented specifications
v" A restricted access location for the Host
v" A copy of Microsoft™ SQL Server 2008 with Management Studio

SQL Server Parameters
Microsoft™ SQL Server must be installed with the following parameters.

Item Value

o The Installation program requires SSQL mixed mode.

Authentication o The Windows user performing the installation must be a part of the
“Administrators” group and hold administrator privileges.

Login Set automatically.

Password Set automatically.

Table 4: Microsoft™ SQL Server 2008 Requirements
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4: Installation

The Integration software is distributed on CD, the contents of which must be loaded on a
dedicated LAN-based Server designated as the “Responder Application PC.” The CD will
check for a valid PC host environment—including available drive space, OS versions, DB
installation, and components (11S, .NET 2.0 framework)—and will alert you of any issues.

Updating an Existing Installation...

If you are updating an existing installation, you must use the Add/Remove Programs applet
(Control Panel) to remove the RBI-ADT prior to loading a newer version:

Existing configuration and data (beds, mapping, patients) are kept when updating an existing
installation.

To Load the Software:
1 Insert the CD into an available drive.
2 Double click on SetupADT.exe.
» The Components screen will appear.
3 Click on Install.
» The RBI_ADT setup wizard will appear:

I
Welcome to the RBI_ADT Setup Wizard A

The installer wil quide pou through the steps required ta install RBI_ADT on your computer

WWARMING: This computer pragram is protected by copyright law and international treatiss,
Unauthorized duplication ar distribution of this program. or anw portion of it, may result in severe civil
or criminal penalties, and will be prosecuted to the maximum extent possible under the law.

Cancel cnmck [ mes |

Page 12 of 81



KI-2246C Responder 5 ADT Interface—Installation, Setup, and Service

4  Click on Next.
» The Select Installation Folder screen will appear:

[ RBI_ADT = =]
L

Select Installation Folder A

The installer willinstall REI_ADT to the following folder.

To irestall in this folder. click "Mest". Toinstall to a different folder. enter it below or click "Browse".

Folder

IE WProgram Files\Fauland-BorgWREI_ADTY Erowse... |
Disk Cost... |

Concel | <Back |[ Hes |

» Do not change the default installation folder entry.
5 Click on Next.
» The Confirm Installation screen will appear:
JSTal

Confirm Installation [l

The installer is ready to install REI_ADT on your computer.

Click "Mest" to start the installation.

Concel | <Back |[ Hes |

» The License Agreement screen will appear:

& RBI_ADT B s 4

License Agreement (el

Pleass take a moment to read the lisense agreement now. I you accept the terms below, click. |
Agree”, then "Next”. Othenwize click "Cancel'

-
Software License Agreement ﬂ
This is a legal agreement between Rauland-Borg Corporation (Rauland) and the
purchaser of the hardware product manufactured by Rauland with which this
software product is intended to function (LICENSEE). Rauland agrees to license
to LICENSEE and LICENSEE agrees to license from Rauland this computer
software on the following terms and conditions.
All rights to the Responder Software (Licensed Software) are owned by Rauland- LI

" | Do Mot Agree @ | Agres

Cancel | < Back I Mext > I

6 Read and agree to the license agreement.
7 Click on Next.
» The Installation Program screen will appear:
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ST E

Installing RBI_ADT A
]

RELADT iz being installed

Please wait..

Conced | | <back || Hes |

» The Browse for SQL Server screen will appear:

x4
Server: |FIEEM j

Port: I

ADT database: |ResponderADT

Component database: IRBl_Components

Data folder: | =]

6 Windows Authenfication (Admiri )
" SOL Server Authentication

User name: Isa

Password: I

Cace_|

» Should you have a specific reason for doing so, you may choose a new location for
the SQL Server database.
» Leave the Database Name and Windows Authentication defaults in place.

8 Click OK.
» The Create Database screen will appear:

RI=EY

Install Database

Stopping service: Service is not installed

Set SQL Serverto Mixed Mode Authertication:OK
Set SQL Agert to Auto-start:OK

Updating database:

Updating web.config: OK
DOMNE!

OKl
4
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9 Click OK.
» The Installation Complete screen will appear:
S
Installation Complete LT‘\

RELADT has been successfully installed.

Click *"Close" tor exit.

Please use Windows Lpdate ta check for any critical updates to the NET Framewark.

Cancel | Cose |

10 Click on Close.
» The main Install screen will reappear.
11 Click on Close.
» The Responder ADT Web Ul shortcut will appear on your desktop:

F i

Fl?amnder
ADT Web UL
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5: Touring the Interface

In this chapter, you’ll learn how to use the Interface. The Interface is comprised of multiple
dynamic panes, dropdown menus, controls, and buttons.

Because the Interface is customizable, your views may differ from the ones in this guide.
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Reload from database

Interface Selector (Customize Views)
Dropdown Menus

¥ HL7 fon ADT Intenrface

File Actions Style Service Help Admin

1, Select an action from the .
- Action Menu
- Action List Direct Action Buttons (Customize Actions)
- Action Buttons Quick Action Selector (Wizard)

START HERE: Select an action ADT Link Login Type

ADT Interface Status jEEEEEEEsEEEEEEEEEEEwE
HOME SCREEN .
. .
Connection Status
4
( Refresh )

.
= Message Fields
-
1

EEsEsEEsEEEEEEEEEES
ADT Meszage Counts

Previous Minute
a a 0

| Y] ge Details Grow/shrink web page
Status and Navigation Bar ~ #e=zages w/shrink web pze

NC Bzd Patient Name Patient ID Account ID Date Time

Context-specific navigation buttons—Cancel, Back, Next, and Finish:

l <t Cancall < Back l HNext > l Finizh >> ]

Figure 2: Interface Home Screen
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Logging In to the ADT Interface

In order to begin the setup process, you must first login to the ADT Interface:

To Login:
1 Locate and double click on the Responder ADT Web Ul Login desktop icon:

» Or, enter the following URL in your IE browser:
HTTP://yourServerlP/RBI_ADTweb/default.aspx).

» The Login screen will appear:

B v View: ? Rauland Responder
File Actions Style Service Help Admin

1. Enter your User Name and Password now.

1 User Name:

1 Password:

2 Enter the following default administrator information:
» User Name: Admin
» Password: Admin01

3 Click on Login.
» The Home Screen will appear.
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< HLT for ABT Interfoce

You may use the “New Password” button to change the default/current password:

User Mame:
[Admin
Passwaord:
I.......
Loginl [ e Passwor-.l
fl ' ‘o
N
O *
\
.
MNew Password ’
| -
&7

Confirm Mew Password:

ox |

Accessing and Using the Wizard

You can access the wizard from the Actions menu, Quick Action Selector, or Direct Action
Buttons. (You may have to click on the Cancel or Finish buttons in order to return to the
Home Screen.)

¥ HL7 for ADT Interface

File Actions Style Service Help Admin

Figure 3: Actions Menu

I START HERE: Select an action l

Figure 4: Quick Action Selector (Setup Wizard)

Figure 5: Direct Action Buttons
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To Access and Begin Using the Setup Wizard:
1 Open and log into the Interface.

» The menu bar, Quick Action selector, and/or Direct Action buttons will appear:

~ HL7 for ADT Interface

File Actions Style Service Help Admin

1. Select an dgtion from the ..,
- Action M Actions menu
- Action List

- Action Buttons Direct Action Buttons
Quick Action selector

START HERE: Select an action

ADT Link Event Test Purge Events

Figure 6: Menu bar, Quick Action Selector, Direct Action Buttons

> You’ll use either the Actions menu or the Quick Action selector to access and begin
using the Wizard.

> You may later use the Direct Action buttons to engage any of the individual
configuration options.

2 Click on the Quick Action selector.
» Wizard steps 1 through 12 will appear in the drop down.

To Control the Setup Wizard:

You can control the Wizard using the context-sensitive control buttons, located at the
bottom of the Interface:
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* HLY for ADT Interfoce

Service Hep Admin

EVET MANBLINS

Figure 7: Wizard Control Buttons

Logging Off

In order to log off, you’ll need to “X” out of the Interface web page.

Dropdown Menus

All functions are accessible via one of the dropdown menus.

¥ HL7 for ADT Interface

File Actions Style Service Help Admin

Figure 8: Interface Menus

File Menu
Only the Print option is currently functional on the File Menu.

File Actions Styld

Figure 9: Interface File Menu

Actions Menu
You’ll use Setup Wizard steps found in the Actions menu to configure the ADT Interface:
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DAY #1: TEST FEED

rnight Errars

rhight

ADDITIONAL SETUP

- Patient
-R

Figure 10: Interface Actions Menu

The Actions menu also provides access to all of the Maintenance functions.

MAINTENANCE

Figure 11: Interface Actions Menu (Maintenance Callout)

Other Things You Should Know:
v" You can only access the Actions Menu from the Home Screen.
v" Clicking on any Cancel or Finish button will return you to the Home Screen.

Style Menu

Should you wish, you’ll use the Style Menu to change the look of the display—screen
design, header text size (not currently functional), color, and facility logo.
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¥ HL7 for ADT Interface

File Actions Style Service Help Admin

1. Select an acti
- Action dhenu
BUNSTCNE [ - Screen Design
- Action Buttol m

SHARED BY ALL APPLICATIONS

- Header Text Size
- Color

START HEI - Fucili'h, Lﬂgﬂ

Figure 12: Interface Style Menu

Service Menu

You’ll use the Service menu to view service logs and technical support contacts and set
technical support information.

¥ HL7 for ADT Interface

File Actions Style Service Help Admin

1. Select an action fram
- Action Menu
- Action List
- Action Buttons

- View Service Logs

- Technical Support Contacts ...
B - Set Tech Support Info

Figure 13: Interface Service Menu

SAMPLE =]
B T Y S —— X88-411
- BioMed Engi ing ®83-411

- Responder Authorized Dealer ...... 1-800-867-5309

- 24 Hour Response 1-987-654-3210

Figure 14: Technical Support

Help Menu

You’ll use the Help menu to toggle the Quick Help feature on and off, view the system
help file, access technical support contacts, and set technical support information.
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¥ HL7 for ADT Interface

File Actions Style Service Help Admin

1. Select an action fram
- Action Menu
- Action List
- Action Buttonz

- View Service Logs

- Technical Support Contacts ...
B - Set Tech Support Info

Figure 15: Interface Help Menu

File Actions Style Service Help Admin

1, Zelect an astion fram the .. ;I
- Action Menu
- Action List
- Action Buttons

Figure 16: Interface Quick Help

The About link provides current Responder 5 Server and Client Apps version details:

RAULAHD INTEGRATION SOLUTIONS ;I
™2

SERVER APPS
-12.00 ADT Interface
-12.00 Location Interface

CLIEHT APPS
- ¥i.HX  All apps to date are Server Apps

Figure 17: Help | About

Admin Menu
You’ll use the Admin menu to set technical support information.
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Tech Support Contact Information
SAMPLE A
= FACHT IS covmeoeeeerens s sencemsssseseenes x68-11

- BioMed Engineering ®53-H1

- Responder Authorized Dealer ...... 1-800-867-5309

- 24 Hour RESPONSE wvssssssessnsmssnsnsn 1-987-654-3210

Auto-Email upon Failures
Email Address
tech.support@myHospital.org
SMTP Server Name
mySMTPserverdame

[ Test Email | E

Customize Printout Header
Facility Name
myFacilityHame

| Cancel | 0K

Figure 18: Interface Menu

Quick Action Selector

Depending on the screen design you’ve chosen, you may see the Quick Action selector,
which allows you to access all of the options available on the Actions menu.

DAY #1: TEST FEED
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Direct Action Buttons

The Interface supports 25 listed actions; five (5) of these actions can appear at any time as
“Direct Action Buttons”—which are used as shortcuts.

Figure 19: Direct Actions Buttons

The Interface automatically assigns the most frequently used actions to buttons—unless
you use the Customize Actions feature, which allows you to “Hide Unused Actions,”
“Always” make an action a button, or “Never” make an action a button.

Context-Sensitive Controls

Context-sensitive controls appear on the left side of many screens:

Setup 2 of 12:
EVENT TEST RESULTS

¥ : o corscted (%] = Rejected

n
. =
.
M {r kefresh \_u .
a & J =
= L]
= L]
. g
5 | Sample Events ) !
& J

.
.
. 'f/ Import File \.' .
- -
.
a

|Se lect o message

Figure 20: Context-Sensitive Controls

Status Display (Home Screen)

System status will appear above the message area on the Home Screen:

STATUS EEEEEEEEEEEEEEEEEEEEEEEEEY

Corridor
Light=

—

o B

P @

lc

Databaze
EEEEEEEEEEEEEEEEEEEEEEEER

MESSAGE COUNTS

Previous Hour Previous Minute This Minute

MESSAGES

® pauland Room

Figure 21: Status Display (Home Screen)
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Context-Sensitive Quick Help

In certain display modes, the Context-Sensitive Quick Help box will appear. For instance,
what you see while viewing the Event Test Results screen will differ from what you see
while using the Test Summary screen:

File Actions Style Service Help Admin

1. Send a test event from the ADT system

2. Click REFRESH to see the result

3. Select an event to see its full message

4, Repeat 1 - 3 for each expected event

B, Click FINISH when done Rd

Figure 22: Context-Sensitive Instruction Box (Event Test Results)

Controls and Indicators

You’ll find various context-specific controls and indicators on the Home screen, including
those that impact or show Units, Username, logo, menu ribbon, and screen display.

Interface Selector

Logo
Refresh database _\ Username \ \

~ HL7 for ADT Interface Rauland Responder: Admin e

Figure 23: Interface Controls

Quick Style Toggle
Screen Design Control

\ Option Controls

¥ HL7 for ADT Interface Screen n=custom < EH > <« fP»

Figure 24: Interface Controls 2

OPTIONS ™ Admit patients on ADS update

I Cancel discharge on update

FAILED EVENT RETRY a8 =
LIMIT Defoult = 25
Roulond will ACE the Mth e Limit = 0

wonseoutive retry to prevent

Context-Specific Controls
communication gridlock

EIIS I

Figure 25: Context-Specific Controls
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Interface Toggle

Locator Interface

Figure 26: Interface Toggle (ADT or RTLS “Locator”)
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6: Preparing for Setup

Setup involves the pre-implementation and implementation steps listed below:

Pre-Implementation

Contacts Rauland Technical Support at least two
(2) weeks prior to planned implementation...

@ Provides facility with customized checklist and
guidelines regarding action items and deadlines...
@ Schedules teleconference between distributor,
facility, and assigned Rauland consultant...

Implementation

Installs, configures, and assists in remote

integrity testing via VPN connection...
{Optionally) arranges for on-site Rauland
technical consultation...

Facility

Facility

Figure 27: Pre- and Implementation Overview

Day 0 Setup-Related Requirements

v Have a working R5 system(s).
v" Have a license key for the Interface for each R5 system.

Day 1 Setup-Related Requirements

v Have a completed Installation Prerequisites document for the site.

v" Request Facility IS support from someone with can send controlled trigger events A0l
Admit to A62 Cancel Change Consulting Doctor as needed from the ADT system.
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v

Have the ADT system port number.

Day 2 Setup-Related Requirements

AN NN

Request Facility IS support from someone with can read the ADT system census.
Have a list of all R5 beds.

Have a list of all ADT beds that will be linked to R5 beds.

Have the connection string for each R5 system (defaults are presented on-screen).
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7

7: Setup

After you’ve logged in, setup requires you engage in the following 12 steps in the
following order—over the course of two (2) days:

Step 1: Establish ADT Link (ADT Link)

Of the 12 steps, the first requires you to attend to communication port, timeout, event
handling, option, and failed event retry limit parameters using the ADT Link screen:

aeTETY Takeur

Figure 28: ADT Link Screen

ADT Communication Port

The Interface sits between the facility’s ADT system and the R5 system and communicates
with the ADT system via a specific port.

Default: Port 2021

To Select a Port
1 Type in the port number (provided by the facility’s IS group).

» Use the TEST button to retry the link and refresh port status once you’ve made an
entry:
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SQ"‘IIP 1 of 12: ADT PORT Communication port IEU21 (<] CESt_)
ADT LINK befuueenI the .ﬁ_.lpil;ﬂseyrs;:cr: and befault = 2021 ‘
.;-ullw‘-’%- ' 5
’ . .‘.. l .
o \C, o /4
” .ol" , oy
l F. ACTIVITY TIMEQUT: -\ ‘Iﬁmin vl
O 1442015 13:54:51 Mo recent ADT messoges from thiz part
Part[2021]: Mo connection could be made because the Port[2021] iz not connected to service
target machine actively refused it 127.0.0.1:2021

» Note: it takes 30 seconds for a new port assignment to activate. Update status is
displayed in the left pane:

Setup 1 of 12:
ADT LINK

ADTFort was updated. Wifait 30s for service updateing

to the newr ADTPort.

Setup 1 of 12:
ADT LINK

Part[2021]: Mo connection could be made because the
target machine ootively refuzed it 127.0.0.1:2021

Activity Timeout

ACTIVITY TIMEOUT: |5 min =]
04/ 14/ 2013 14:17:01 : |

You can enter an Inactivity Timeout value in order to mark the link as “failed” after a
period of inactivity and to help determine Interface reliability.

Default: 5 mins.
Range: 5 mins., 15 mins., 1 hr., 4 hrs., 24 hrs., Never

To Set the Inactivity Timeout Value
1 Use the dropdown box to select a timeout value that anticipates false failures.
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Options

OPTIONS | Admit patients on ADB update

I™ Cancel discharge on update

The ADT Link screen requires you make admit and discharge decisions regarding A08
updates:

Admit patients on A08 update

The system can be set to re-sync (correct previous census errors) on each A08 update,
which is a) typically the most common message in normal operation, b) the simplest for 1S
personnel to generate manually, c¢) helpful for initial census population, and d) a sound way
to maintain accurate census during continued operation.

To Use the A0O8 Update Feature

o Check the Admit patients on AO8 update to cause each A08 update—containing a
bed, but no discharge date—to admit or transfer the account to the bed if not already
there.

Cancel discharge on update
Check the Cancel discharge on update to if wish to send an A08 discharge message.

Event Handling

EVENT HANDLING Foulond ¥ Paticnt Beds
will support multiple HLT

cohnections. Select the purpose(z)

of thiz connection

Because Responder 5 can report multiple HL7 connections, you must determine the
purpose of the ADT connection.

The only Event Handling option for the T12 software version is Patient Beds. Note: this
feature has not yet been implemented.

Failed Event Retry Limit

FAILED EVENT RETRY
LIMIT

The ADT system typically retries failed events until manually made to skip the failed
message—potentially causing an endless “loop”; therefore, you may wish to enter a Failed
Event Retry Limit, which will automatically prevent endless loops.
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A Retry Limit will NAK consecutive failed events until the limit is reached, log the limit,
ACK the event, and automatically prevent an endless loop.

Default: 25.
No limit: 0.
Range: 0-100.

To Set the Failed Event Retry Limit
1 Use the dropdown to select the limit.

» If the limit is triggered, the system logs the Failed Event Retry data (Service | View
Service Logs).

Step 2: Test Trigger Events (Event Test Results)

Next, you should test compatibility to insure that Facility 1S understands how the Interface
handles each and every HL7 event sent by the ADT system:

B - HL7 for ABT Tuterface

Help Admin

Figure 29: Event Test Results

@ Test each facility trigger event, one at a time.

To Test a Trigger Event
1 Send a single trigger event from the facility ADT system.
2 Click on REFRESH.

3 Review the response (AA accept or AE error) and patient census reaction (MOVE TO,
MOVE FROM, and REMOVE) in the Message box:
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LAST EVENT

ADT Bed Patient ID Account ID
Event ADT AD2 TRAINIMGI, 102.1  Abramsson02, Abral PID_02T AID_02T -

— Move From TRAININGI, 102, 2 AbramssonD2, Abral PID_02T AID_02T
— Move To TRAININGI 1021  AbramssonD2, Abral PID_02T AID_02T
Response AA x|

TEST STATISTICS

# Event Sent =2
# Error Events =0
Event Rate (Events/Sec) = 6.47

4 Repeat for each ADT trigger event type.

Step 2A: View Sample Events (ADT Event
Simulation)

View/send known good events in a loopback (from the Interface to the Interface).

Satup 2 of 120 TEST EVENT OFTIONS
AT GVENT stwuLaTION  IEEESEETEEIEN =

Io

e

TEST STATISTICS
8 Eveet et
# Erver Eventt
Event Bate vt Sac)
Tort Stert Tims

Tonr s i

TESULT eTans
[’ e C pr— D € e X e

Figure 30: ADT Event Simulation

Standard Events

If any particular ADT trigger event from the facility does not work, sample events can be
sent to view the exact message and how the Interface handles it.

To Send a Standard Event
1 Select the trigger event(s) to send.
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TEST EVENT OPTIONS

( Test ’
Standard Events
- AD1 Admit

t Refresh )
- ADZ Transfer

- 403 Discharge

- AD4 Register

- A0S PreAdmit

- Aé Transfer Out to In

- ADT Transfer In to Out

- ADE Update

- All Cancel Admit o

|»

- AlZ Cancel Transfer

- Al3 Cancel Discharge

- ALT Swaop

- A18 Merge Patient Info
- AZ3 Delete Patient

- AZ& Add Person

- AZ9 Delete Person

- A30 #herge Person

2 Clickon TEST.
» The Custom Test Message summary will appear:

Gartom Test Messoge for ALT Event Simulation

[WSHI=\A]SendingAgp|Sendingt-ac iy | 2007 110612401| ADT 401 [ e trilt- AD3-1]PI2-2/—AR3 Duacharge
[EVRa A [Z00T11 061249
[PID 1 [PerTt_03T|PTD_B3TIARID, 4 Abrahan” A 5 03T]12345-6703
100111 {161 A S Do PHO| T 2" le Ferrar” Rafasl 8- LT Dr" ATt o1
[Pl ARt Chest 14" Tssdation,
{PORI[11IHendicap]
L1 HIPenicatin
488121 | Ay llin
[ALI13 || Amyeatin
[oeat| ([ AmaraScteranis

[Lati2 |ArrinSeiresit
[oeal8| otherSclerosis

403 | MessCIrilD- AO3-24P|2.2

-
[Evel 03] 200711041 260
[FIG|IPerTD_00TIFT_0OT|APID, " Abeaban™A" | QITHRY-4%6T00
[P 11 TRATMING 3031 15 Ateandies” Asila" A°Se° U PHO| T01 2 Re farrerRafine R LT Be MO 1111 Ambubetony 1| T01 3* A= Acka” AT b
[Pz ARY Chest HIGhIPCE PC4" Trslatuan, ]

C )
» Test messages can be used by Rauland personnel during troubleshooting.
3 Click on SEND.
» The results will appear:

LAST EVENT
’_ Event ADT Bed MName Patient ID Account ID
Event ADT AQS Albertsondg, Alberto PID_08T AID 08T
—- Update Albertson08. Alberto PID_08T AID 08T
Response AA
\.U = Aure- Correched 9 = iz eres
TEST STATISTICS
# Event Sent =2
# Error Events =0
Event Rate (Events/Sec) =1.65

Test Start Time 4/23/2013 11:30:24 AM

> Review the response (AA accept or AE error) and patient census reaction (MOVE
TO, MOVE FROM, and REMOVE) in the Message box.
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Custom Events

If any particular ADT trigger event from the facility does not work, you can edit, send, and
analyze known good events to pinpoint cause. Consult Rauland Technical personnel for
further assistance with this analysis.

To Send a Custom Event
1 Select the trigger event to use as a baseline.
2 Clickon TEST.
» The Custom Test Message summary will appear:

Custom Tast Massage for ADT Event Simulstion

[WSHI™=A A SendingAeplSendingF aciiry ||| 20071 10812401 | ADT" AD] | Merectril-AG3-1]F12 2| —AB3 Dischargs =]
EVh A1 200711061240

PID(3 [RerTty_03TIPTD_G3TIAPID, ‘Abrobas” A 03T]12345-6703

[PV 11 TRATNINE 100151~ (1001 Atandir® Al 4" Se°LePH | 100 2B farwar™fiafas & LTI Dr" MO 11| Amblatory]| 101 3* A ter Acdam" A" Tt o1
P2 || AL Chest Py 1PCA" Issdatuan, Aggr

P11} Hendicap]

et HiPenicanin

488121 | Ay llin

AL 13| Amystin

o1l [l AmeroScterasis

[ceai2 [ Arrariascioresin

D1 | 3] [OtherSclerosis

M—‘n"ll' 415 DT 403 MassCiril-A03-21P|2.2
Va4l 403 | 200711

Pioi e, GaTIF LD, OYTIAPTD 07T “Abrabanr A o e
P11 ITI TRATMINGE 10371 || I Attander® Atilla® A" srwwlwrmm-rnnturrm Tor” MO 1111 Ambulatory || T 3° Admitter™ Adan™ A" Tr* be”
P21 [ARE"Chent

[

3 Make changes to any entry in the textbox.
4  Select SEND to view the results:

LAST EVENT

ADT Bed Patient ID Account ID
Event ADT AQ2 TRATIMTMGI, 102.1  Abramssond2, Abral PT 02T AID_O2T -
-—- Move From TRAININGI, 102, 2 Abramsson02, Abral PID_02T AID_02T
-—- Move To TRAININGI, 102,1  Abramsson02, Abral PID_02T AID_O2T
Response AA j
" —

TEST STATISTICS

# Event Sent =2
# Error Events =
Event Rate (Events/Sec) = 6.47

» Review the response (AA accept or AE error) and patient census reaction (MOVE
TO, MOVE FROM, and REMOVE) in the Message box.

5 Select NEXT to return to the Event Test Results screen.

Step 3: Review Event Test Summary (Test
Summary)

After you’ve tested trigger events, you should review untested, rejected, and accepted
trigger events:
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== Untested .
Rejected

Accepted

Figure 31: Review Event Test Summary (Test Summary)

You can either save the results as an Excel worksheet or print them as a web page:

To Save the Test Summary as an Excel Worksheet
1 Click on SAVE As (File | Save As).
» The file download dialog will appear:

File Download

Do you want to open or zave thiz file?

Igj Mame: GRIDVALS
il Type: Microsoft Excel Worksheet

From: 127.0.0.1

Open Save | Cancel I

‘ “we While files from the Intemnet can be useful, some files can potentially
\q) harm pour computer. [F you do not trugt the source, do not open or
= save this file, ‘what's the risk?

2 Click OPEN to view the worksheet, or SAVE to save it for later review.

To Print the Test Summary
1 Click on PRINT (File | Print).
» The summary will appear as a web page:
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myFacilitylame
414/2013 4:16:57 PM

Test Events Summary
Untested Events

- A01 Admit

- A02 Transfer

- A03 Discharge

- A04 Register

- A05 Pre-Admit

- A06 Transfer Out to In
- AQ7 Transfer In to Out

- 408 Update Patient Info

Rejected Events

Accepted Events

M Back

2 Click on PRINT.
» The Print dialog will appear:

fmPrint <]

General | DDtionsl

r~ Select Printer
9 Add Prinker

& Document Image Wiker
Diocurnent Writer

%0 Snaqit 10

Status: Ready ™ Printtofile  Preferences |
Location:
Comment: Find Printer... |

~ Page Range
=l Mumber of copies: |1 3:
! Selection; € Curent Page
" Pages |1 ™ Collate
Enter either a single page number ar a single _:llM _212 _31ﬂ
page range. For example, 512

Print I Cancel | Lpply |

Step 4: Restore Defaults (Purge Events)

Once you’ve completed the Events tests, you must purge the database to remove artificial
errors, beds, or patients associated with initial event testing.

Purging this data before retesting or reconnecting the live feed insures that subsequent
statistics and census will reflect only real facility data.
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¥ = HLT for ADT Interfoce

File dtins Style Service Help Admin

Satup 4 of 12:
PURGE BVENTS

Coepea

Figure 32: Restore Defaults (Purge Events)

To Restore Defaults

1 Make sure that you do not require any patient, bed, or event data.
» You cannot restore purged data.

2 Click PURGE ALL.

3  Confirm your action:

Message from webpage

:' Are you sure? You will lost all bed mapping!

oK I Cancel |

Step 5: Review Overnight Summary (Test
Summary)

On the second day, you should review the overnight summary—which shows untested,
rejected, and accepted trigger events. Rejected events offer insight into how to adjust the
Interface engine.

Page 40 of 81



KI-2246C Responder 5 ADT Interface—Installation, Setup, and Service

* HLT for ADT Interfoce

Help Admia

Untested
jec

@ acemmin

Accepted

Figure 33: Review Overnight Summary (Test Summary)

To Save the Test Summary as an Excel Worksheet
1 Click on SAVE As (File | Save As).
» The file download dialog will appear:

File Download [ %]
Do you want to open or save thiz file?
Ig ] Mame: GRID.ELS
Hl Type: Microsoft Excel Worksheet

From: 127.0.0.1

Open Save | Cancel I

‘..'-\ While files from the Intemmet can be ugeful, some files can potentially
" harm your computer. | you do not tust the source, do not open or
= save this file. ‘What's the risk?

2 Click OPEN to view the worksheet, or SAVE to save it for later review.

To Print the Test Summary
1 Click on PRINT (File | Print).
» The summary will appear as a web page:
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myFacilitylame
414/2013 4:16:57 PM

Test Events Summary
Untested Events

- A01 Admit

- A02 Transfer

- A03 Discharge

- A04 Register

- A05 Pre-Admit

- A06 Transfer Out to In
- AQ7 Transfer In to Out

- 408 Update Patient Info

Rejected Events

Accepted Events

M Back

2 Click on PRINT.
» The Print dialog will appear:

fmPrint <]

General | DDtionsl

r~ Select Printer

9 Add Prinker

= Microsoft Office Document Image Wriker
4PS Document Writer

%0 Snaqit 10

Status: Ready ™ Printtofile  Preferences |
Location:
Comment: Find Printer... |

~ Page Range

& Al Mumber of copies: |1 3:

! Selection; € Curent Page

: I
" Pages 1 ™ Collate _LM _2,2 _3,ﬂ

Enter either a single page number ar a single
page range. For example, 5-1

Print I Cancel | Lpply |

Step 6: Review Overnight Errors (Error Events)

The Trigger Event Error log shows the most recent failed and problematic events.
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T < WL fur ADT Tnterface

Style Service Help Adamin

Event ™. ADT Bed

D Event ADT ADL A TUB, 330.01 MASS0LT, TENMIFER. M
(%] —— Response AE

Rauland Bad Patient ID Account ID Date Time

s Message | Wiassaga Fialds)

-
Select o message Kd =

Event Error Detail

To Save the Test Summary as an Excel Worksheet
1 Click on SAVE As (File | Save As).
» The file download dialog will appear:

File Download | x|
Do you want to open or save this file?
@ Mame: GRID.XLS
1l Type: Microsoft Excel Warksheet

From: 127.0.0.1

Open Save | Cancel I

‘--"\l While files fram the Intemet can be useful, some files can potentially
d harm pour computer. | you do not tust the source, do not open or
= save this file. What's the risk?

2 Click OPEN to view the worksheet, or SAVE to save it for later review.
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To Print the Test Summary
1 Click on PRINT (File | Print).
» The summary will appear as a web page:

myFacilityName
4/15/2013 103025 AM

Events Report

Event RaulandBed ADTBed PatientName PatientID AccountID Date Time ADTBedlD it EventlD  HL7MessagelD

Print | Back

2 Click on PRINT.
» The Print dialog will appear:

fmPrint [>]
General | Dphnngl
i~ Select Printer
8 Add Prinker

Status: Feady ™ Printtafie  Preferences |

Location:
CammieRE Find Printer... |
~ Page Range
A MNumber of copies: |1 32
! Selection, ) Curent Page
" Pages I'I ™ Collate
. . . 1 1 2 2 3 3
Enter either a zingle page number or a zingle
page range. For example, 512

Print I Cancel | Apply |

Step 7: Review Overnight Census (Bed Census)

Census data indicates the success of the overnight census test. It is also the first place to
review Rauland/ADT patient data consistency.

Help Adnin

Figure 35: Review Overnight Census (Bed Census)
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To View the Bed Report
1 Click on BED REPORT:

C s veor )

» The Bed Report screen will appear:

» Clicking on any entry in the upper pane will show details in the lower.

To View the Patient Report
1 Click on PATIENT REPORT:

( Patient Report )

» The Patient Report screen will appear:

» Clicking on any entry in the upper pane will show details in the lower.

To Save the Test Summary as an Excel Worksheet
1 Click on SAVE As (File | Save As).
» The file download dialog will appear:
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Do you want to open or save GRID.XLS from 127.0.0.17 Open | Save |v| Cancel
2 Click OPEN to view the worksheet, or SAVE to save it for later review.
To Print the Census Results
1 Click on PRINT (File | Print).
» The results will appear as a web page:
myFacilityMame
4/15/2013 11:56:37 AM
Bed Census Data
Rauland Bed ADT Bed Patient Name Patient ID Accaunt ID MeBedID ADTBedID
1,3501,1,1 64
1,3803.1.1 &5
ER, 24 RW TEST, ORDERREVIEWDUDBE E189570 8908806 ¥
TRAINMIMGL, 1011  AronsonOl, Aaren, A PID_OIT ALD_ 01T 1]
ICU, 35031 1,3803,1 OTTER, EMMET MOC0000021 VOOOOO0O0028 24 59
rec. RM3B01. 1 135011 26 57
rec, RM3502.1 1,3802.1 BUCK, DAFFY MOCCO0000T  VOODOO000004 28 58
rec, RM3502, 2 1,3502,2 29 &2
chaff RM3504,1 1 35041 1n &0
staff, RM3505,1 1 350111 Berg, Erik MO00000020 VOOOO00000Z0 13 63
staff, RM3B05,1 1, 3505.1 13 &1

] o]

2 Click on PRINT.
» The Print dialog will appear:

General | Dptionsl

i~ Select Printer

H‘.?.'J.':mdd Prinker
e Microsoft Office Document Image Writer

g:Mic 'S Diocume: riter

Status: Ready I Printtafie  Preferences |
Location:
Comment: Find Printer... |

[ Page Range
A Murber of copies:
 Selection ) Curent Page

" Pages |1 I~/ Collate

page range. For example, 512

Enter either a zingle page number ar a single _:llH _le _3lj

Prirk I Cancel

| Apply |

3 Click BACK to return to the results screen.

To Discharge a Patient

1 Select any entry in the entry in the Bed Census list.
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Rauland Bed ADT Bed Patient I
1,101, 1 Church, Eric
3,301 1 Bayer, Madeline
3,302 1 Sherman, Linda
4,401, 1 Gutknecht, John
4,402, 1 Luther, Frank
4, 403, 1 Andrews, Roy

2 Click on DISCHARGE:

o

( Discharge

3 Confirm the discharge:

Setup 7 of 12:
BED CENSUS Rauland Bed ADT Bed Patient I
11081 Church, Eric
3. 3011 Bayer, Madeline
3, 3021 Sherman, Linda
4, 401, 1 Gutknecht, John
(' fefresh \)’I 4,402.1 Luther, Frank
4, 403, 1 Andrews, Roy
4,404, 1
I\f Bed Report \}1 4,405, 1 i
) ) 4, 406, 1 'e' Are you sure to discharge this patient?
I( Patient Report \),l 44071
. ’ 4, 408, 1
4,409, 1 O I Cancel
4, 410, 1

4 Repeat as necessary.
5 Click NEXT to move on the step 8/12.

Step 8: ADT Bed List (ADT Bed)

You can use the ADT Beds setting to display the name and link status of each ADT Bed in
Add. the Interface database; you can also use it to manually “express” add/delete beds, and/or
Setup lock the bed list.
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B - L7 for ADT Istarface

File Servica Help Admin

Select e basts frem Fatentis!
Climk Add or Daluts 7 spaty

Setup 0 of 12)
ABT BED

Lbim aIFEL BELS =

AUTOMATIC BEU ENTRY s

WATUAL EXTRESS BED vy
ENTRY nmy

Unrfff):'l?apped
Beds

Figure 36: ADT Bed List (ADT Bed)

Manually Adding ADT Beds

You can add beds manually without waiting for messages from the ADT system regarding
each bed. Manual addition also prevents extra beds from being entered into the database.

To Manually Add Beds

1 Select ADT BED LIST from the Quick Actions Selector, dropdown menu, or Direct
Action buttons.

2 Enter the facility, unit, room, and up to four (4) bed suffixes:
3 Click on UPDATE.
» The Potential Beds list will appear:

Facility
|Hue,ksrm
Unit Room Bed

——,
[ast fr00 Ii B |5 [+ (_Update )
TRAININGI, 100, 1 TRAININGIL, 100, 2 TRAININGIL, 100, 3 TRAININGIL, 100, 4 el
TRAININGI, 101, 1 TRAININGIL, 101, 2 TRAININGL, 101, 3 TRAININGI, 101, 4
TRAININGI, 102, 1 TRAININGIL, 102, 2 TRAININGL, 102, 3 TRAININGIL, 102, 4
TRAININGI, 103, 1 TRAININGIL, 103, 2 TRAININGI, 103, 3 TRAININGI, 103, 4
TRAININGI, 104, 1 TRAINIMNGIL, 104, 2 TRAININGI, 104, 3 TRAININGL, 104, 4
TRAININGL, 105, 1 TRAINIMNGI, 105, 2 TRAININGIL, 105, 3 TRAININGIL, 105, 4
TRAININGI, 106, 1 TRAINIMNGL, 106, 2 TRAININGI, 106, 3 TRAININGL, 106, 4

4 Select the beds you wish to add from the potential bed grid.
» Use the ctrl/click combination to highlight multiple beds.
5 Click on ADD:

TRAIMNIMNGI, 196, 4
TRAIMIMNGL, 197, 4

TRAIMNIMNGI, 198, 4
TRAIMIMNGI, 199, 4 -

Add >

6 Repeat for each unit.
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Manually Deleting ADT Beds

Because response times deteriorate as the database grows, it is best to remove beds
appearing in the Unmapped Beds list. Note: a smaller database requires less scrolling
during Bed Report bed selection.

To Manually Delete Beds

1 Select ADT BED LIST from the Quick Actions Selector, dropdown menu, or Direct
Action buttons.

2 Select the beds you wish to delete from the Unmapped Beds list:

UMM APPED BEDS

4,418, 1 |

[ < belete .\}

» Note: you cannot delete linked beds; unlink them (Bed Mapping screen) first.
3 Click on DELETE.
4 Repeat until all extra beds are deleted.
5 Lock the bed list.

Locking the ADT Bed List

Locking the ADT Bed List allows you to filter out beds. Locking the beds after initial
installation is the best way to filter out unwanted beds—for instance: “pre-op” and
“outpatient.”

To Lock the ADT Bed List

1 Select ADT BED LIST from the Quick Actions Selector, dropdown menu, or Direct
Action buttons.

2 Check the LOCK ADT BED LIST checkbox:
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AUTOMATIC BED ENTRY % " Lock ADT bed list

MANUAL EXPRESS BED -
EMTRY Facilrty

Step 9: Establish Rauland Links (Rauland Link)

In order for the facility’s ADT system to communicate with Responder databases, you
must identify a Rauland link.

Add.
Setup

Setep 9 of 12: RAULAND BATARASE ] <o L)
RAULAND LINK

Figure 37: Establish Rauland Link (Rauland Link)

To Establish a Link
1 Clickon EDIT:

RAULAND DATABASE  |Rouland Dotabasel | 0( Test )

Total Rauland Databases: 1 @

1-Edl'f.'

» The link fields will open:

Ilﬂ-_lam [ratabasel LI (% ] ( Test )

|pO-DBS =1 ——r

Host\SQL Name:[P0-b85

Database Nume:lrﬁapp 85 Ao
User ID:[R5_ADT e

Passw cnr‘d'.l-‘tliiT ADT

» Note: the unlabeled dropdown field allows you to search all available SQL Servers:
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[Feam ~| ( Find

HosHSQL Name: FraNknBs FRANKDES

PO-DBS
PO-BRS
|RSDBASE

LE L RSREPORTS
Password:|RANDYRDS
RANDYRERS
RISHLY
RR52008
SC-DBS
localhost

Save ) (D-eleie)

2 Make Database Name, User ID, and Password selections to create a connection string
for the Responder system.

» The defaults are:

Database MName:

Item Default Entry
Database Name R5App
User ID R5_ADT
Password ADT

» Once a valid link to the Responder system is established, insure that all Responder
Beds are linked.

3 Click on TEST to retry links and refresh the status indicator.
4 Click on SAVE when you have completed editing.

=

Leave the Rauland Responder connection unconfigured during initial testing to prevent test data
from being passed to the Responder system.

To Add a Connection String
You would only add a connection string if one doesn’t already exist.
1 Click on EDIT:

RAULAND DATABASE  [nouiond Defabasel [ 9( = )
Total Rauland Databases: 1 €
\ Edit )

» The link fields will open, bearing the ADD control:
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3

RAULAND DATABASE  [Rouland Databasel o)
[o-DBS =] Fincll_dj
Host\SQL Name:[Po-b83
Database ane\lrﬁap-p- RS Anp
User TD:[R5_ADT a5_ADT
Password:{ADT ADT
Total Rauland Databases: [ %]

o il i, ——e. ——
V() (o) (oeere)

Make Database Name, User ID, and Password selections to create a connection string
for the Responder system.

Click on ADD.

To Delete a Connection String
You would delete a connection string when switching from one database to another.

1

2

Click on EDIT:
RAULAND DATABASE  [2cuiard Dotabasel SO T )
Total Rauland Databases: (%]
Edit
» The link fields will open, bearing the DELETE control:
RAULAND DATABASE  [aauiond Devabasel 1O Test )
|Po-bBS =] Find
Host\SQL Name:|P0-DBS
Database Name:|rSepp R5App
User TD:fR5_ADT RS _ADT
Passw Ur‘d'.lleT ADT
Total Rauland Databases: [ ]
(" add ) Save M( belete )

Click on DELETE.

Step 10: Rauland Bed List (Rauland Bed)

You can use the Rauland Bed List to display the name and link status of each Rauland Bed

Add.
Setup

in the Interface database; you can also use it to manually add or delete beds.
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L HLT fer ADT Interfoce

Figure 38: Rauland Bed List (Rauland Bed)

Manually Adding Rauland Beds

Manually adding beds can quickly populate the database and allows for immediate bed
mapping. Manual addition is particularly useful when the Rauland system is likely to grow
over time.

To Manually Add Rauland Beds
1 Select RAULAND BED LIST from the Quick Actions Selector or dropdown menu.
2  Enter the facility, unit, room, and up to four (4) bed suffixes:
3 Click on UPDATE.
» The Potential Beds list will appear:

Facility
|ank5h'ﬂ
Unit Room Bed

ey
[East1] [t0a I F ||| CQuedsed
TRAININGL. 100. 1 TRAININGI. 100. 2 TRATNING, 100. 3 TRATNING1, 100. 4 &
TRAININGL. 101. 1 TRATNINGI. 101. 2 TRATNINGH, 101. 3 TRAININGI. 101. 4
TRAININGL. 102. 1 TRAININGI. 102, 2 TRATNING, 102, 3 TRATNING1, 102, 4
TRAININGI, 103,1 TRAININGI. 103.2 TRAININGI. 103. 3 TRAINIMNGI. 103, 4
TRAININGI. 104, 1 TRAININGL. 104, 2 TRAININGI. 104. 3 TRAINIMNGI. 104, 4
TRAININGL 105.1 TRAININGI. 105, 2 TRAININGI. 105. 3 TRAINIMNGI. 105, 4
TRAININGI. 106.1 TRAINIMGL. 106, 2 TRAININGL. 106. 3 TRAINIMNGI. 106, 4

4  Select the beds you wish to add from the potential bed grid.
» Use the ctrl/click combination to highlight multiple beds.
5 Click on ADD:
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TRAIMNIMNGI, 196, 4
TRAIMIMNGI, 197, 4

TRAIMNIMNGI, 198, 4
TRAIMNIMGI, 195, 4 -

Add >

6 Repeat for each unit.

To Manually Delete Rauland Beds

Changes in a Rauland system can cause obsolete Rauland beds to show in the Interface
database; removing these beds will improve system performance.

To Manually Delete Rauland Beds

1 Select RAULAND BED LIST from the Quick Actions Selector or dropdown menu, or
the RAULAND BEDS Direct Action button.

2 Click on the EDIT icon at the top of the Rauland bed list:

RAULAND BEDS %f‘.._‘_j.

Euilt-in Facility Awies!, 4401 1
Bullt-in Facility 4West, 4402, 1
Euilt-in Facility 4viest, W4dl, 1

Builiin Facility  4West, w402, 1 The @’_"} icon indicates a bed is linked

in the Interface, but missing from

Bullt-in Facility A4vvest, WalZ_ 80 .é

Bulll-in Facility  4West, w402, 80 @ the R5 or integrated system.
Euilt-in Facility 4West, W4al3 1

Euilt-in Facility 4\West, W43, 2

Euill=irs Foilily Aviresl, Va4, 1

Euilt-in Facility 4WWest, W45, 1

Euilt-in Facility 4est, W4dé, 1

Bullt-in Facility Aest, W4T, 1

Bui =i Facility 4viest, W4D0, 1

Built=in Facility dwest. Wale, 1

Euilt-in Facility dwiest, W4lD, 1

Bl lt-in Facility Avest, WALl 1

Gullt-in Facility Aiest, W4l2, 1

Euilt-in Facility 4West, W4l3, 1

Built«in Facility Aviest, Wald, 1 =l

3 Select the beds no longer in the Rauland system.
» Note: you cannot delete linked beds; unlink them (Bed Mapping screen) first.
> Note: a bed will automatically reappear if it is still part of the Rauland system.
4 Repeat until all extra beds are deleted.

Step 11: Map ADT Beds to Rauland Beds (Bed
Mapping)

Mapping (linking) ADT and Rauland Beds insures that a patient in an ADT Bed is shown
Add. in the corresponding Rauland Bed.
Setup
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T - LT for ADT Tnterface

Style Service Help Admin

ANT WSS ) wavvane wos T umn wees

oot Y|P -
nosest = by -

Unked
Beds

Figure 39: Map Beds (Bed Mapping)

Note:

Link multiple ADT beds to a single Rauland bed if your ADT system differentiates a single
physical bed based on room occupancy (private vs. semi-private) or patient status (labor vs.
delivery vs. post partum) or unit (swing beds).

To Link Beds

1 Insure the ADT and Rauland Bed lists are up to date.
2 Selectan ADT Bed.
3 Select a Rauland Bed link target:

ADT BEDS ~—) RAULAND BEDS (= )

ﬁm-_—'! m-_-
ER. 24, RW i ui cility ~ TIcU.3503.0 -

. TRAININGI, 101, 1 k-‘ Bull'hﬁﬁ I€U, 35031 =

|1 1,3501.1 == Built-in Faci TCu, 3903.2

1 1, 8501, 1, 1 B {Built-in Facility  rec, RMS501, 0 =i

1 1.3502.1 =2 Builtin Facilify  rec. RM3501.0 =]

1 1,3502, 2 = Buitin Facility  rec, RM3501, 1 =)

1 1.3503.1 52 | |BuilinFacility  rec. RM3501.1 =

1 1,3503,1.1 | |BuiltinFacility  rec,RM3502,0 & |

lz 1,3504,1 = x| |suitinFacility  rec.RM3502.0 e &

C Lmke )

4  Click on LINK.

o tink>— 2

» Linked Beds appear in the Linked Beds list:
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LIMNKED BEDS
-m
1 1.3503.1 Built-in Faci ICU, 3503, 1

1 1.3501.1 == Built-in Faci rec, RM3501. 1 45

1 1,3502.1 =2 Built-in Faci rec, RM3502, 1 47

1 1, 3502, 2 == Buili-in Faci rec, RM3502, 2 48

1 1,3504.1 == Buil-in Faci staff, RM3504. 1 49

1 1.3505.1 =% Built-in Faci staff, RM3505. 1 51

1 1.3501. 1.1 % Built-in Faci staff, RM3505. 1 51

5 Repeat for each unlinked Rauland bed.
6 Remove extra facility (ADT) beds.
7 Lock the bed database for optimum performance:

AUTOMATIC BED ENTRY © Lock ADT bed list

MANUAL EXPRESS BED .
EMTRY FIJCI|IT‘;'

Figure 40: ADT Bed Screen (Step 8/12)

Step 12: Map ADT Fields to Rauland Fields (Field
Mapping)

Field Mapping allows you to assign an HL7 segment/field/component source for each
Add. ADT display field in the Rauland system. Some facilities may deviate from the HL7
Setup standard regarding trigger event information. Other facilities may want additional

information that is not part of the Interface data defaults. Coded fields can be translated

into readable strings, and compound fields can be translated into separate readable strings.

You’ll use the Fields filters (Required, Standard, Custom, Translated) to control what
appears in the mapping grid:

= HLY for ADT Isterfoce

Figure 41: Map Fields (Field Mapping)

The Required Fields grid includes the following fields:
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Required Fields
Name Editable
Rauland Field No
HL7 Field Yes
Components Yes
Default Field No
Description No
Table 5: Field Mapping, Required Fields
Standard Fields
Name Editable
Rauland Field No
HL7 Field Yes
Components Yes
Translated Yes
Default Field No
Description No
Table 6: Field Mapping, Standard Fields
Custom Fields
Name Editable
Rauland Field No
HL7 Field Yes
Components Yes
Table 7: Field Mapping, Custom Fields
Translated Fields
Name Editable
Rauland Field Yes
HL7 Field Yes
Components Yes

Table 8: Field Mapping, Custom Fields

Note: add * at the end of the HL7 field (AL1-03*, for example) to combine repeating segments.
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To Map Fields

Required and Standard Fields

Using the Required Fields or Standard Fields filter...

We strongly recommend not changing required fields.

(op]

Select the Required Fields or Standard Fields filter:

Required Fields ™ Standard Fields " Custom Fields  Translated Fields

Edit the Segment and Field (separated by a dash) within the mapping grid (SSS-FF).
Edit the component(s) within the mapping grid (C) or (C, C, C).

Terminate the entry with a “*”—if all repeating segment fields are to be combined to
create this information.

Click on SAVE.
( Save )
Repeat for each custom field.

» View the census fields after receiving new trigger events containing data in the
custom fields to test your mapping configuration.

Custom Fields

A W N

»

Edit the Field Name.
Edit the Segment and Field (separated by a dash) within the mapping grid (SSS-FF).
Edit the component(s) within the mapping grid (C) or (C, C, C).

Terminate the entry with a “*”"—if all repeating segment fields are to be combined to
create this information.

Click on SAVE.
( Save )
Repeat for each custom field.

> View the census fields after receiving new trigger events containing data in the
custom fields to test your mapping configuration.
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(2

O3

Translated Fields

Make sure to check the “Translated” box (Standard filter screen) for any field you wish to
translate. Fields bearing a check will auto-appear on the Translated filter screen:

| Translated
1.2.3 -
1 -
2 ' -
3 ' -
1 |
1 ' i
— - -
1 » =)
6.2 Y -
* Translated
la
". ‘. — ’.&
-#l‘. a‘

Field Sources

1 Edit the Segment and Field (separated by a dash) within the mapping grid (SSS-FF).

2 Edit the component(s) within the mapping grid (C) or (C, C, C).

3 Terminate the entry with a “*”—if all repeating segment fields are to be combined to
create this information.

4  Click on SAVE.

g save )
5 Repeat for each field.

Translations

B - 27 fer ADT Tntarface

1 Click the “...” button column.
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2 Enter a desired display string.

3 Enter the search string(s)—semi-colon delimited—to cause the display string to be sent
to the Responder 5 applications.

> Note: use the up/down arrows at left to insure proper search order. A search will stop
when the first string is found.

Display value is. ..
Click Detaill button on Translated field
table to get franslation detail of
S 170

4  Click on SAVE.

C Save )
5 Enter the default display value (must be a search string, or NULL, or Raw (passes field
untranslated).
6 Click on SAVE.
7 Repeat for each display string
» Review census fields after receiving new trigger events containing custom field data.

b AN
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8

8: Service Access, Diagnostics, and
Maintenance

In addition to the fully privileged administrator login, a unique limited access “Service
Login” is available which provides access to maintenance tools, but not configuration
settings.

Logging In: Service Access

In addition to the fully privileged administrator login, a unique and restricted access login
is available. Those logging in under the “Service” login can only access diagnostic tools;
they cannot access/edit configuration settings.

To Login Using the Service Credential

1 Access the Interface login page.

2 Enter the default Service case-sensitive Login/Password information:
» Login = Service
» Password = Servicel

3 Click on Login.
» The Home Screen will appear, bearing diagnostic/maintenance links:

¥ HL7 for ADT Interface

File Actions Style Service Help

MAINTENANCE

- Review Census

- Review Errors

- Bed Report

- Patient Report

- Remove an Improper Patient

Customize Actions
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Maintenance

You can access the five (5) Maintenance options via the Actions menu or Quick Action
selector. They are:

Review Census

Review Errors

Bed Report

Patient Report

Remove an Incorrect Patient

Review Census

A census review providing bed-by-bed patient information can confirm success of the
overnight test. It is also the first place to look to resolve incorrect or missing patient data
within the Rauland solution.

Here’s how to perform the review:

To Review the Census
1 Select File/Save as or File/Print (File menu) to save or print a copy of the census.
2 Compare the Interface census to the ADT system census.

3 Investigate any discrepancies between the Bed Report or Patient Report options—for
instance, if a patient does not show up as expected in a particular bed.

4  Click on FINISH to return to the home screen.

Review Errors (Error Events)
You can review the most recent failed trigger events using the Review Errors utility.
To Review Recent Failed Trigger Events

1 Select Review Errors from the Actions menu or directly from the Bed Census screen.
» The Error Events screen will appear:

= HLT fur DT Intarfoce

Errors

Error Details

2 Select an error item.
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» Message details will appear in the lower pane—either in message or message field
form.

3 Select File/Save to save a copy.

Bed Report

The Bed Report shows a brief history of bed-related trigger events. If a Census Review
reveals that the Interface census data does not match the ADT census data, you can
typically find the reason in the trigger event history.

To View the Bed Report
1 Select Bed Report from the Actions menu or Quick Action selector:

BED CENSUS

( Refresh )
( Discharge __{5
¢ Bed Report )
( Patient Report )

Select the ADT or Rauland Bed to review.

Review the bed’s transaction history.

Select a reaction to see details of the implicated trigger event.
Click on FINISH.

g B~ WDN

Patient Report

The Patient Report shows patient-related data. If a Census Review reveals that the Interface
census data does not match the ADT census data, you can typically find the reason in the
trigger event history.

To View a Patient Report
1 Select Patient Report from the Actions menu or directly from the Bed Census screen:

BED CENSUS

(4 Refresh )
¢ bischarge b
€ Bed Report )
( Patient Repart )

» The Patient Report will appear:
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= HLT fur DT Intarfoce

[y ——

Select the Name, Account, or ID of the patient to review.
Review the patient’s transaction history.

Select a reaction to see details of the implicated trigger event.
Click on FINISH.

g B~ WN

Remove an Incorrect Patient

The Remove an Incorrect Patient utility allows you to manually remove a patient from the
Interface database without a discharge re-send or new ADT system admit transaction. Use
this option if a synchronization error results in a discharged patient remaining in a bed.

To Manually Discharge a Patient
1 Select Remove Patient from the action menu, list, or buttons.
» The Bed Census screen will appear:

B - UL7 foe ABT Tutertace

Vel Adwin

2 Select the bed or patient from the census display.
3 Click on DISCHARGE.
4 Confirm your action:
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BED CENSUS
(— ) D
C Discharge D
¢ Bed Report )
C Patient Report )
x|

o~
ie‘ Are you sure to discharge this patient?

Lo ] cod |

» The census will update.
5 Click on FINISH.
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A

Appendix A: Customizing the
Interface

In this chapter, you’ll learn how you can use the Style menu to change the look of the
Interface—customizing screen design, header text size, color, and facility logo. You can
apply different styles to the Admin and Service logins.

Style Service Help Admin

SHARED BY ALL APPLICATIONS
@J - Screen Design

ﬁ - Header Text Size

s - Color

- Facility Logo ...

Figure 42: Home Screen, Style Menu

@ Because the Interface is customizable, your views may differ from the ones in this guide.

Note: if the menu is not visible, use the pulldown control @ at the top right of the screen:

Screen Height Control

You can adjust the height of the screen to fill your display and minimize scrolling using the
resize controls, located in the bottom right corner of the screen:
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~ HLY for ADT Interface
File Actions Style Service
1. Selec an action from the ..
- Action Menu
- Action List -
- Action Buttons
START HER=: Select anartis
ADT Interface =
HOME SCREEN
‘ Re~resh

Figure 43: Screen Height Control

To change the screen height:

1 Click on either the up arrow (") to shrink the size of the Interface web page or the
down arrow (") to grow the size.

Screen Design

You can configure the screen design to maximize usable screen space, to provide level-
appropriate on-screen operational hints, to accommodate mouse or touchscreen, etc. by
adjusting one or more of the following options:

On-screen help, with highlighted auto-favorite action buttons and fully-descriptive action list

On-Screen help, with highlighted actions and auto-favorite unit tabs

Men-touch, multi-actien user without on-screen help

Auto-favorite touchscreen compatible action buttons, plus highlighted action list, without on-screen help
Multi-view / multi-action user with auto-favorite view tabs, without action highlights or on-screen help

Maximum screen space: no actions, help, menu, or view switching

Highlights on-screen help, aute-favorite touchscreen compatible buttons, view switching, and facility logo

Figure 44: Screen Design Menu

To change the screen design:
1 Select Screen Design from the Style menu:
Style Service Help Admin

SHARED BY ALL APPLICATIOMS
I - Screen Design

i P8 - Header Text Size
= Color

- Facility Logo ...

=KD Lin

2 Select one of the available screen design options:
e Helpful
e Unit Hopper
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e Mouse

e Touch

e View Hopper
e Read Only

e Demo

> If it appears, you may also cycle through all screen design options using the Screen
Design selector:

Screen Design = Helpful < @ > « . » x

Screen Design selector

Header Text Size

You can use the Header Text Size adjustment to select small, medium, or large text
headings:

SHARED BY ALL APPLICATIONS
| [E - screen Design
P8 - Header Text Size Small

I - Color Medium
- Facility Logo ... Large

Color (Themes)

You can change theme colors to accommodate preference, display characteristics, and
ambient lighting.

To change the default color:
1 Click on the Color option (Style | Color).
2 Select one of the available theme colors:
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GEMSTONES

- Ruby
Garnet
Amethyst
Sapphire

Aquamarine

Jade

METALS
Patina
Platinum
Silver
Steel
Pewter
Bronze
Gold

Copper
Figure 45: Style Options, Color Choices

The new color theme will appear:

45T baireps Gomy

Figure 47: Style Options, Color (Example 2)
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Facility Logo

You can insert a facility picture or logo to display in the upper right hand corner of the web
page.

To replace the default logo:
1 Create a JPG logo file measuring 62 x 272 pixels.
2 Contact Rauland Technical Support.
» The support team will take and install your logo image on the server.

To change the default caption:
1 Type over the existing caption.

Image File
Defaultimage.gif

Caption
my Hospital Hame

I Cancell £ oK

Figure 48: Style Options, Logo Settings (Default)

2 Click Preview.
» The new caption will appear beneath the logo image:

Page 70 of 81



KI-2246C Responder 5 ADT Interface—Installation, Setup, and Service

Font size selector

Image File
Defaultimage.gif

Caption
Washington Hospital

+—— Caption reset

I Cancel | | OK -

Figure 49: Style Options, Logo Settings (Custom)

3 Use the font selector to cycle through the three (3) available font sizes—small,
medium, and large.

4 Click on the OK button to save and exit the logo window.

Customize Actions

The Interface supports 25 listed actions; five (5) of these actions can appear at any time as
“Direct Action Buttons”—which are used as shortcuts.

Figure 50: Direct Actions Buttons

The Interface automatically assigns the most frequently used actions to buttons; however;
you can use the Customize Actions feature to

v Hide Unused Actions

v Always (make an action a button)

v Never (make an action a button)

To Customize Actions

1 Choose Customize Actions from the Actions menu.
» The action options will appear.

2 Make your selection.
> If you choose “Always” or “Never”...

3 Click on any of the items in the expanded Actions list.
» An adjacent check mark confirms your selection(s):
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Actions Style Service Help Admin

DAY #1: TEST FEED

- 1. Establish ADT Link

- 2. Test each Trigger Event

- 3. Review Event Test Summary

- 4. Restore Defaults (Start Live Feed)

DAY #2: LIVE FEED

- 5. Review Overnight Summary
- &. Review Overnight Errors

- 7. Review Overnight Census

ADDITIONAL SETUP
- 8. ADT Bed List

- 8. Establish Rauland Link SELECTED (CHECKED) ACTIONS

- 10. Rauland Bed List BECOME ACTION BUTTONS
- 11. Map ADT Beds to Rauland Beds

- 12. Map ADT Fields to Rauland Fields

DAY #1: TEST FEED

- 1. Establish ADT Link
MAINTENANCE - 2. Test each Trigger Event
- Review Census - 3. Review Event Test Summary
- Review Errors - 4. Restore Defaults (Start Live Feed)

- Bed Report
DAY #2: D

e e 1 [+ 5 et i Sener |
v = 5. Review Overnight
- Remove an Improper Patient 5

- 6. Review Overnight Errors

Customize Actions HidG-UﬂHScd Actions - 7. Review Overnight Census

ADDITIONAL SETUP
Never a Button - 8. ADT Bed List
- 9. Establish Rauland Link
- 10. Rauland Bed List
- 11. Map ADT Beds to Rauland Beds
- 12. Map ADT Fields to Rauland Fields

MAINTENANCE

- Review Census

- Review Errors

- Bed Report
- Patient Report
- Remove an Improper Patient

Customize Views

Because Interface components are shared between the HL7 for ADT and RTLS “Locator”
Interfaces, you can choose to keep or remove View Tabs. View tabs allow you to toggle
between Interface when both are installed.

To Customize Views
1 Choose Customize Views from the Interfaces dropdown.
> The available Interfaces will appear:
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+ HL7 for ACT Interface

LN ) Q>
INTERFACES

- HL7 for ADT Interface
- Locator Lnterface

Custemize Views Hide Unused Views

ENABLED (CHECKED) VIEWS

Nev'r a Tab
BECOME VIEW TARS

INTERFACES

v = HLT for ADT Interface

- Locator Interfoce

’~'-r.?'

2 Make your selection.
» If you choose “Always” or “Never”...

3 Click on either of the Interfaces in the expanded Actions list.
» An adjacent check mark confirms your selection(s).

Technical Support Contact Information

Logging into the Interface as an administrator allows you to record Technical Support
Contact Information that appears to any user.

To Enter Technical Support Contact Information
1 Access the Set Tech Support Info link (Admin or Help menus):

prvice Help Admin

M - Set Tech Support Info

» The Style Options | Tech Support Settings page will appear:
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Tech Support Contact Infarmation

SAMPLE i
B it 11T L-j——— L
- BioMed Engineering ... £83-411

- Responder Authorized Dealer ...... 1-800-867-5309

- 24 Hour RESPONSE ....eceeeeeeeeee. 1-987-654-3210

e

2 Position your cursor and enter or change details.
» Fields only accept letters, numbers, spaces, dashes, and periods.
3 Click on OK when you are satisfied with the contact information.
» The data entered here will appear on the Technical Support Contacts screen (Help

menu):
SAMPLE =]
B 1 1 L ————— x88-411
- BioMed ENgineering .. ®E3-411

- Responder Authorized Dealer ...... 1-300-867-5309

- 24 Hour RESPONSE usssmssmmsmninn 1-987-654-3210

Failure Notification

Using the Auto-Email upon Failures feature, the Interface can automatically send a failure
notice to any single email address.

To Establish the Auto-Email upon Failures Recipient
1 Access the Set Tech Support Info link (Admin or Help menus):

prvice Help Admin

M - Set Tech Support Info

» The Style Options | Tech Support Settings page will appear:
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. Auto-Email upon Failures
Email Address
tech.support@myHospital.org
SMTP Server Name
mySMTPserverHame

=

2 Enter a valid email address in the Email Address field.
3 Enter avalid SMTP Server Name.
» The SMTP server is responsible for generating outgoing mail.
4 Click on OK when you are satisfied with the contact information.

Custom Printout Header

Should you wish, you may use the Custom Printout Header feature to create a custom
report header, bearing the facility’s name.

To Customize Printout Header
1 Access the Set Tech Support Info link (Admin or Help menus):

prvice Help Admin

M - Set Tech Support Info

» The Style Options | Tech Support Settings page will appear:
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alpha A digit / space £ dash { dot only

2 Delete the current name.
3 Enter the new name.

» The field will only accept letters, numbers, spaces, dashes, and periods.
4  Click on OK.
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Appendix B: Icon Legend

The Interface may display any of the following icons:

Icon Function/Explanation
i | Link is active, or status is good
&3 | Link has failed, status is failed, message failed, or error
L) | Some links have failed
% | Warning
1) | Message caused a resync auto-correction in R5

=4 | Item is linked

b

Item is not linked

L) | Ignore
=2 | Item is linked multiple times
& | Item is linked in Interface, but is now missing from R5 or integrated system
£} | Undo or restore default
{4 | Redo
2F | Item has been edited. You must save it.
72 | Delete
(¥} | Zoom in
{=} | Zoom out
Expand item
Collapse Item
Grow window size
Shrink window size
Dropdown list
,af‘ Text size
+1 | Refresh

Next option for this setting

Previous option for this setting

Next setting

Previous setting

Close

Table 9: Application Icons
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C

Appendix C: Trigger Events Processed

You’ll find all of the codes that may and do not affect the census in the following two (2)
tables. Important: codes marked with a double asterisk (**) are required ADT trigger
events. They are:

A01 Admit

AO02 Transfer Patient

AO03 Discharge/End visit

AO06 Transfer Outpatient to Inpatient

AOQ7 Transfer Inpatient to Outpatient

A08 Update Patient Info

AR N N N NN
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Events that May Affect the Census

**A01 Admit

**A02 Transfer Patient

**A03 Discharge/End Visit

A04 Register Patient

**A06 Transfer Outpatient to Inpatient

**A07 Transfer Inpatient to Outpatient

**A08 Update Patient Info

Al1l Cancel Admit

A12 Cancel Transfer

A13 Cancel Discharge

AL7 Swap Patients

A18 Merge Patient Info

A23 Delete Patient Record

A28 Add Person/Patient Info

A29 Delete Person Info

A30 Merge Person Info

A31 Update Person Info

A34 Merge Patient Info ID only

A35 Merge Patient Info Account Only

A36 Merge Patient Info, ID and Account

A39 Merge Person/Patient ID

A40 Merge Patient Identifier List

A41 Merge Account: Patient Account#

A43 Move Patient Info: Identifier List

A44 Move Account Info: Account#

A46 Change Patient ID

A47 Change Patient ID List

A49 Change Patient Account#

A54 Change Attending Doctor

A55 Cancel Change Attending Doctor

A61 Change Consulting Doctor

A62 Cancel Change Consulting Doctor

P02 Purge Patient Account

P05 Update Account

P06 End Account

Table 10: Codes that May Affect the Census
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Events that Do Not Affect the Census

AO05 Pre-Admit Patient

AQ9 Patient Arriving

A10 Patient Departing

Al4 Pending Admit

Al5 Pending Transfer

A16 Pending Discharge

A20 Bed Status Update

A21 Patient Leave of Absence

A22 Patient Leave of Absence Return

A25 Cancel Pending Discharge

A26 Cancel Pending Transfer

A27 Cancel Pending Admit

A32 Cancel Patient Arriving

A33 Cancel Patient Departing

Ab2 Cancel Patient Leave of Absence

Ab3 Cancel Patient LOA Return

P01 Add Patient Account

Table 11: Codes that Will Not Affect the Census
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D

Appendix D: Common HL7 Myths

Do not make assumptions regarding any HL7 implementation. Not understanding the
following rules can result in a loss of synchronization with the ADT system.

An account ID will always be present...

Not so. Rauland permits field mapping to allow another field (typically the Patient ID) to
be used in place of the account ID.

Account IDs will be unique to a patient/incident...

Not so. Rauland permits field mapping to allow another field (typically the Patient ID) to
be used in place of the account ID.

There will always be a patient ID/MRN present...

Not so. Rauland permits field mapping to allow another field (typically the Social Security
# for a VA hospital) to be used in place of the Patient ID.

HL7 segments will arrive in a pre-defined order...

Not so. R5 looks for the field anywhere within the message, and will process it regardless
of order. The MSH segment is the only exception; it must occur first.

Every Trigger Event from the ADT System will reach its destination...

Not so. Unexpected events impact networks, servers, databases, and application software.
Rauland maintains a history of events, but never rejects a message based on previous
history. Instead, the Interface software will accept the new message and update the census
based on the latest information, giving special markings to census actions that were caused
by an apparent out-of-sync condition.

A configuration setting allows A08 updates to admit a patient, as long as the message
contains a valid bed, account, and patient ID; does not contain a discharge date; and no
discharge date had previously been received.

There will be only one discharge date/time for an Account...

Not so. There can be discharge dates and times set as a patient moves from one area (ED)
to another (inpatient) even if the same account# is used in both areas. The Interface
software offers a configuration option that allows a ReAdmit (equivalent to A13 Cancel
Discharge) upon receiving an A08 Update to allow resynching of census for previously
discharged patients.
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